The Notebook Review forums were hosted by TechTarget, who shut down them down on January 31, 2022. This static read-only archive was pulled by NBR forum users between January 20 and January 31, 2022, in an effort to make sure that the valuable technical information that had been posted on the forums is preserved. For current discussions, many NBR forum users moved over to after the shutdown.

Precision 7520 and ThunderBolt3 connection problem/driver problem

Discussion in 'Dell Latitude, Vostro, and Precision' started by jkrzyszt, Dec 23, 2021.

  1. jkrzyszt

    jkrzyszt Notebook Enthusiast

    Likes Received:
    Trophy Points:
    Hello, I'm looking for help with my Precision 7520 and its Thunderbolt connector.

    I bought an external case for the eGPU Sapphire GearBox for the ThunderBolt3 connector.

    Unfortunately, after connecting, the housing is detected as an ordinary USB hub, but it does not see it as a THunderBolt device, charging does not work, etc.

    The case was connected to another Dell Precision 7550 laptop and there it is correctly detected as thunderbolt, i.e. it is visible in the ThunderBolt COntrol Center software, reports charging with a maximum power of 90W, etc.

    So far I have done, updated the thunderbolt module firmware (Dell ThunderBolt Firmware Update, A08). I have installed the drivers from the Dell website with the number Intel-Thunderbolt-Controller-Driver_TBT79_WIN_17.4.79.510_A12.

    Unfortunately, these drivers are recommended to work with Windows 1909 and old (I have Windows 20H2 64bit).
    When I connect the eGPU to the thuderbolt connector, it is not detected.

    Therefore, I tried to install the drivers from Intel's website (I found such an entry somewhere on the www forum), and I tried the TBT-Win10-1.41.1193.0 version. Unfortunately, after connecting the eGPU with these drivers, an exclamation mark appears in the device manager next to the ThunderBolt Controller 15D9 device with the error code 43.

    The eGPU on another ThuderBolt laptop is working fine, but not in my Precision 7520, it seems to be a driver problem.
    How to make thunderbolt work properly?

Share This Page